Resolved
The issue is resolved. Please refresh your browser and sign in again.
Email support@gc.ai if you are still having issues.
Identified
GC AI is recovering. Please refresh your browser and sign in again.
Investigating
GC AI sign-in is failing with the error "There was an error retrieving your information. Please contact support@gc.ai."
We are aware and working on a resolution.