Resolved
Our upstream providers have confirmed the issues have been resolved.
Investigating
We have identified our sign up page and file upload are degraded currently.
Investigating
Various GC AI services are degraded due to an underlying issue with one of our service providers.