Login errors have been fully resolved. Document upload is fully functional.
Resolved
Monitoring
Login page is showing errors for some users.
Identified
Login service and document upload are experiencing errors due to an Amazon AWS incident.
·